C贸mo solucionar el error 芦CodeQL analyses from advanced configurations cannot be processed when the default setup is enabled禄 en GHAS

Pues eso 馃槞, estuve un buen rato intentando averiguar c贸mo solucionar este error que mi querido GitHub Advanced Security me estaba dando en uno de mis workflows con CodeQL:

CodeQL analyses from advanced configurations cannot be processed when the default setup is enabled

Este se ha producido al tener configurado previamente Code scanning con CodeQL, deshabilitarlo y luego crearme un workflow en modo avanzado.

Para solucionarlo, debes ir a las Settings de tu repo y en el apartado Code security and analysis, en los tres puntos, hacer clic en la opci贸n Switch to advanced:

Settings – Code security and analysis – Switch to advanced

Y ya est谩 馃コ

隆Saludos!